PT-2024-6209

CVE-2024-32608

·

Published

2024-05-14

·

Updated

2024-11-08

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions HDF5 library versions prior to 1.14.4
Description The issue is related to memory corruption in the H5A close() function of the HDF5 library, resulting in the corruption of the instruction pointer. This can cause denial of service or potential code execution. The vulnerability is associated with a heap buffer overflow, which can be exploited by a remote attacker to cause a denial of service.
Recommendations For HDF5 library versions prior to 1.14.4, update to version 1.14.4 or later to resolve the issue. As a temporary workaround, consider disabling the H5A close() function until a patch is available. Restrict access to the HDF5 library to minimize the risk of exploitation. Avoid using the HDF5 library for critical operations until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
ECHO-811D-F445-328E
OESA-2024-2337
OESA-2024-2338
OESA-2024-2339
OESA-2024-2340
OPENSUSE-SU-2024_2195-1
OPENSUSE-SU-2024_3144-1
RHSA-2025:3801
SUSE-SU-2024:2105-1
SUSE-SU-2024:2195-1
SUSE-SU-2024:3144-1
Found an issue in the description? Have something to add? Feel free to write us 👾