PT-2024-6212

CVE-2024-32605

·

Published

2024-05-09

·

Updated

2026-08-25

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions HDF5 Library versions prior to 1.14.4
Description The issue is related to a heap-based buffer over-read in the H5VM memcpyvv() function in the H5VM.c file of the HDF5 library. This can be exploited by a remote attacker to impact the confidentiality, integrity, and availability of protected information. The H5VM memcpyvv() function is called from H5D compact readvv in H5Dcompact.c.
Recommendations For HDF5 Library versions prior to 1.14.4, update to version 1.14.4 or later to resolve the issue. As a temporary workaround, consider restricting access to the H5VM memcpyvv() function until a patch is available.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
AZL-40556
AZL-40685
ECHO-E4EC-4896-121B
OESA-2024-2337
OESA-2024-2338
OESA-2024-2339
OESA-2024-2340
RHSA-2025:3801
Found an issue in the description? Have something to add? Feel free to write us 👾