PT-2024-6310

CVE-2024-45409

·

Published

2024-09-10

·

Updated

2026-10-08

Description by

CVSS 3.1
10
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N
Name of the Vulnerable Software and Affected Versions Ruby-SAML versions prior to 1.17.0 Ruby-SAML versions 1.13.0 through 1.16.0 GitLab versions prior to 17.3.3, 17.2.7, 17.1.8, 17.0.8, and 16.11.10
Description The vulnerability is related to the Ruby SAML library, which is used for implementing the client side of a SAML authorization. The issue arises from the library's failure to properly verify the signature of the SAML Response, allowing an unauthenticated attacker with access to any signed SAML document to forge a SAML Response or Assertion with arbitrary contents. This enables the attacker to bypass the authentication mechanism and potentially gain unauthorized access to sensitive data and critical systems. The vulnerability is actively being exploited, and users are advised to update their GitLab installations to the latest version.
Recommendations For Ruby-SAML versions prior to 1.17.0: Update to version 1.17.0 or later. For Ruby-SAML versions 1.13.0 through 1.16.0: Update to version 1.17.0 or later. For GitLab versions prior to 17.3.3, 17.2.7, 17.1.8, 17.0.8, and 16.11.10: Update to the respective latest version or apply the security patch. As a temporary workaround, consider enabling two-factor authentication for all user accounts and setting the SAML 2FA bypass parameter to 'do not allow' until a patch is applied.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-CVP8-5R8G-FHVQ
GHSA-JW9C-MFG7-9RX2
BIT-GITLAB-2024-45409
DLA-3949-1
DSA-5774-1
USN-7309-1
Found an issue in the description? Have something to add? Feel free to write us 👾