PT-2024-6376
CVE-2024-41946
·
Published
2024-08-01
·
Updated
2026-09-29
Description by
CVSS 2.0
7.8
HighMetricsAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
REXML versions prior to 3.3.3
Description
The issue is related to an uncontrolled resource consumption in the REXML XML toolkit for Ruby. When REXML parses an XML with many entity expansions using the SAX2 or pull parser API, it can lead to a denial of service. If untrusted XMLs are parsed with SAX2 or pull parser API, users may be impacted by this issue.
Recommendations
For versions prior to 3.3.3, update to REXML gem 3.3.3 or later to fix the vulnerability.
As a temporary workaround, avoid parsing untrusted XMLs with SAX2 or pull parser API until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾