PT-2024-7146
CVE-2024-43483
·
Published
2024-10-08
·
Updated
2026-10-01
Description by
CVSS 4.0
8.8
HighMetricsAV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:H/SC:N/SI:N/SA:N
Name of the Vulnerable Software and Affected Versions
.NET versions prior to 8.0.9
.NET versions prior to 6.0.34
.NET Framework (affected versions not specified)
Visual Studio (affected versions not specified)
Description
The issue is related to algorithmic complexity in the .NET platform, .NET Framework, and Visual Studio editor. It may allow a remote attacker to cause a denial of service.
Recommendations
For .NET 8.0 applications, update to version 8.0.9 or later.
For .NET 6.0 applications, update to version 6.0.34 or later.
For .NET Framework, at the moment, there is no information about a newer version that contains a fix for this vulnerability.
For Visual Studio, at the moment, there is no information about a newer version that contains a fix for this vulnerability.
Found an issue in the description? Have something to add? Feel free to write us 👾