PT-2024-7758
CVE-2024-31227
·
Published
2024-10-02
·
Updated
2026-09-18
Description by
CVSS 3.1
9.8
CriticalMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Redis versions prior to 7.2.6 and 7.4.1
Description
The issue exists due to insufficient input validation in Redis, allowing a remote attacker to cause a denial of service. An authenticated user with sufficient privileges may create a malformed ACL selector, which when accessed, triggers a server panic and subsequent denial of service.
Recommendations
For Redis versions prior to 7.2.6, upgrade to version 7.2.6 or later.
For Redis versions prior to 7.4.1, upgrade to version 7.4.1 or later.
As a temporary workaround, consider restricting access to the ACL selector feature until a patch is applied.
Avoid using the
ACL selector feature in affected versions until the issue is resolved.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾