PT-2024-8124

CVE-2024-21198

·

Published

2024-10-15

·

Updated

2025-03-17

Description by

CVSS 2.0
6.8
Medium
MetricsAV:N/AC:L/Au:S/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions: MySQL Server versions 8.0.39 and prior MySQL Server versions 8.4.2 and prior MySQL Server versions 9.0.1 and prior
Description: The issue is related to insufficient input validation in the Server: DDL component of Oracle MySQL Server. It allows a high-privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server.
Recommendations: For MySQL Server versions 8.0.39 and prior, update to a version later than 8.0.39 to resolve the issue. For MySQL Server versions 8.4.2 and prior, update to a version later than 8.4.2 to resolve the issue. For MySQL Server versions 9.0.1 and prior, update to a version later than 9.0.1 to resolve the issue. As a temporary workaround, consider restricting network access to the MySQL Server to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
ALSA-2025:1671
ALSA-2025:1673
ALT-PU-2024-14481
ALT-PU-2024-14548
ALT-PU-2024-14706
ALT-PU-2024-14708
AZL-50391
AZL-50418
CESA-2025_1673
INFSA-2025_1671
INFSA-2025_1673
OESA-2024-2287
RHSA-2025:1671
RHSA-2025_1671
RHSA-2025:1673
RHSA-2025_1673
RLSA-2025:1671
RLSA-2025:1673
USN-7102-1
Found an issue in the description? Have something to add? Feel free to write us 👾