PT-2024-8546

CVE-2024-48208

·

Published

2024-09-18

·

Updated

2025-07-03

Description by

CVSS 2.0
9.0
High
MetricsAV:N/AC:L/Au:N/C:P/I:P/A:C
Name of the Vulnerable Software and Affected Versions Pure-FTPd versions prior to 1.0.52
Description The issue is related to the domlsd() function in the ls.c file of the Pure-FTPd FTP server, which is associated with an out of bounds read in memory. This can be exploited by a remote attacker to disrupt the user's connection to the server.
Recommendations For versions prior to 1.0.52, update to version 1.0.52 or later to resolve the issue. As a temporary workaround, consider restricting access to the vulnerable domlsd() function until a patch is available.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Weakness enumeration
Related identifiers
OPENSUSE-SU-2025:15266-1
Found an issue in the description? Have something to add? Feel free to write us 👾