PT-2024-9096

CVE-2024-52338

·

Published

2024-06-13

·

Updated

2026-07-29

Description by

CVSS 2.0
10
Critical
MetricsAV:N/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions: Apache Arrow R package versions 4.0.0 through 16.1.0
Description: The issue is related to the deserialization of untrusted data in IPC and Parquet readers, which allows arbitrary code execution. An application is vulnerable if it reads Arrow IPC, Feather, or Parquet data from untrusted sources, such as user-supplied input files. This vulnerability only affects the Apache Arrow R package, not other Apache Arrow implementations or bindings, unless those bindings are specifically used via the R package.
Recommendations: To resolve the issue, users of the Apache Arrow R package should upgrade to version 17.0.0 or later. Similarly, downstream libraries should upgrade their dependency requirements to arrow 17.0.0 or later. If using an affected version of the package, untrusted data can be read into a Table, and its internal to data frame() method can be used as a workaround, for example, read parquet(..., as data frame = FALSE)$to data frame().
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALT-PU-2025-11941
AZL-53423
AZL-53471
JLSEC-2026-804
PYSEC-2024-161
Found an issue in the description? Have something to add? Feel free to write us 👾