PT-2025-10408
CVE-2024-12114
·
Published
2025-03-07
·
Updated
2025-03-12
Description by
CVSS 3.1
4.3
MediumMetricsAV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Name of the Vulnerable Software and Affected Versions
FooGallery – Responsive Photo Gallery plugin versions prior to 2.4.30
Description
The issue allows authenticated attackers with granted access and above to update arbitrary post and page content due to missing validation on a user-controlled key (
img id) in the foogallery attachment modal save AJAX action. This requires the Gallery Creator Role setting to be a value lower than 'Editor' for there to be any real impact.Recommendations
For versions prior to 2.4.30, update to version 2.4.30 or later to resolve the issue. As a temporary workaround, consider setting the Gallery Creator Role to 'Editor' or higher to minimize the risk of exploitation. Restrict access to the
foogallery attachment modal save AJAX action to prevent unauthorized updates to post and page content. Found an issue in the description? Have something to add? Feel free to write us 👾