PT-2025-10416
CVE-2024-13816
·
Published
2025-03-07
·
Updated
2025-03-08
Description by
CVSS 3.1
5.4
MediumMetricsAV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
The Aiomatic - Automatic AI Content Writer & Editor plugin for WordPress versions prior to 2.3.7
Description
The issue allows authenticated attackers with Subscriber-level access and above to perform unauthorized actions, including updating and deleting posts, listing and deleting batches, listing assistant uploaded files, deleting personas, deleting forms, deleting templates, and clearing logs, due to missing capability checks on multiple functions.
Recommendations
For versions prior to 2.3.7, update to version 2.3.7 or later to resolve the issue.
As a temporary workaround, consider restricting Subscriber-level access and above to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾