PT-2025-10560
CVE-2024-43107
·
Published
2025-03-10
·
Updated
2025-03-15
Description by
CVSS 3.1
7.2
HighMetricsAV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:L
Name of the Vulnerable Software and Affected Versions
Gallagher Milestone Integration Plugin (MIP) versions prior to 4.0.32
Gallagher Milestone Integration Plugin (MIP) version 3.0 and earlier
Description
The issue is related to improper certificate validation, allowing unauthenticated messages, such as alarm events, to be sent to the plugin.
Recommendations
For versions prior to 4.0.32, update to version 4.0.32 or later to resolve the issue.
For version 3.0 and earlier, update to a version later than 3.0, ideally to version 4.0.32 or later, to resolve the issue.
Found an issue in the description? Have something to add? Feel free to write us 👾