PT-2025-11128
CVE-2025-25293
·
Published
2025-03-12
·
Updated
2025-09-26
Description by
CVSS 4.0
8.7
HighMetricsAV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Name of the Vulnerable Software and Affected Versions:
ruby-saml versions prior to 1.12.4 and 1.18.0
Description:
The issue is related to the ruby-saml library, which provides security assertion markup language (SAML) single sign-on (SSO) for Ruby. The library is susceptible to remote Denial of Service (DoS) with compressed SAML responses. This is because ruby-saml uses zlib to decompress SAML responses, and it is possible to bypass the message size check with a compressed assertion since the message size is checked before inflation and not after. This may lead to remote Denial of Service (DoS).
Recommendations:
To resolve the issue, update to version 1.12.4 or 1.18.0, or later, of the ruby-saml library.
As a temporary workaround, consider disabling the use of compressed SAML responses until a patch is available.
Restrict access to the vulnerable ruby-saml library to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾