PT-2025-11141
CVE-2025-1503
·
Published
2025-03-12
·
Updated
2025-03-13
Description by
CVSS 3.1
6.4
MediumMetricsAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions:
WP Recipe Maker plugin for WordPress versions up to, and including, 9.8.0
Description:
The issue is related to Stored Cross-Site Scripting via the Roundup Recipe Name field due to insufficient input sanitization and output escaping. This allows authenticated attackers with Contributor-level access and above to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recommendations:
For WP Recipe Maker plugin for WordPress versions up to, and including, 9.8.0, update to a version later than 9.8.0 to resolve the issue. As a temporary workaround, consider restricting access to the Roundup Recipe Name field to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾