PT-2025-11158
CVE-2025-1119
·
Published
2025-03-12
·
Updated
2025-03-18
Description by
CVSS 3.1
7.3
HighMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Name of the Vulnerable Software and Affected Versions:
Appointment Booking Calendar — Simply Schedule Appointments Booking Plugin for WordPress versions up to 1.6.8.5
Description:
The issue arises from the software's failure to properly validate a value before executing
do shortcode, allowing unauthenticated attackers to execute arbitrary shortcodes. This is due to the software permitting users to execute an action without correct validation.Recommendations:
For versions up to 1.6.8.5, update to a version later than 1.6.8.5 to resolve the issue.
As a temporary workaround, consider restricting access to the
do shortcode function until a patch is available. Found an issue in the description? Have something to add? Feel free to write us 👾