PT-2025-11340
CVE-2025-27835
·
Published
2024-11-12
·
Updated
2026-05-13
Description by
CVSS 3.1
9.8
CriticalMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Artifex Ghostscript versions prior to 10.05.0
Ghostscript (affected versions not specified)
Description
A buffer overflow issue exists in Ghostscript when converting glyphs to Unicode within the
psi/zbfont.c file. This can potentially lead to denial of service or arbitrary code execution if specially crafted document files are processed. The issue affects versions prior to 10.05.0. Reports indicate that this vulnerability has been publicly known for approximately 8 months and may be exploitable through opening malicious LibreOffice documents or via servers utilizing ImageMagick for file conversion. The vulnerable code resides in the psi/zbfont.c file, specifically during the glyph to Unicode conversion process.Recommendations
Upgrade to Ghostscript version 10.05.0 or later.
Upgrade to Ghostscript version 10.0.0~dfsg-11+deb12u7 for Debian bookworm distribution.
Upgrade to Ghostscript version 10.05.1-alt1.
Found an issue in the description? Have something to add? Feel free to write us 👾