PT-2025-11378

CVE-2024-58103

·

Published

2025-03-16

·

Updated

2025-03-16

Description by

CVSS 3.1
5.8
Medium
MetricsAV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:L
Name of the Vulnerable Software and Affected Versions: Square Wire versions prior to 5.2.0
Description: The issue is related to the lack of recursion limit enforcement on nested groups in ByteArrayProtoReader32.kt and ProtoReader.kt. This could potentially lead to issues when processing certain data.
Recommendations: For versions prior to 5.2.0, update to version 5.2.0 or later to resolve the issue. As a temporary workaround, consider restricting the use of nested groups in ByteArrayProtoReader32.kt and ProtoReader.kt to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-PWF9-Q62P-V7WC
Found an issue in the description? Have something to add? Feel free to write us 👾