PT-2025-11385
CVE-2025-1624
·
Published
2025-02-23
·
Updated
2025-03-17
Description by
CVSS 3.1
3.5
LowMetricsAV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
GDPR Cookie Compliance WordPress plugin versions prior to 4.15.9
Description
The issue concerns the GDPR Cookie Compliance WordPress plugin, which does not properly sanitize and escape some of its settings. This could allow high-privilege users, such as administrators, to perform stored cross-site scripting attacks, even when the unfiltered html capability is disallowed, for example, in a multisite setup.
Recommendations
For versions prior to 4.15.9, update to version 4.15.9 or later to resolve the issue. As a temporary workaround, consider restricting the use of the plugin's settings to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾