PT-2025-12057
CVE-2024-10720
·
Published
2025-03-20
·
Updated
2025-03-20
Description by
CVSS 3.1
8.2
HighMetricsAV:N/AC:H/PR:N/UI:R/S:C/C:L/I:H/A:H
Name of the Vulnerable Software and Affected Versions
phpipam/phpipam version 1.5.2
phpipam/phpipam versions prior to 1.7.0
Description
A stored cross-site scripting (XSS) issue exists in the 'Device Management' section under 'Administration', where an attacker can inject malicious scripts into the
Name and Description fields when adding a new device type. This can lead to data theft, account compromise, distribution of malware, website defacement, and phishing attacks.Recommendations
For version 1.5.2, update to version 1.7.0 to resolve the issue.
For versions prior to 1.7.0, update to version 1.7.0 to resolve the issue.
As a temporary workaround, consider restricting access to the 'Device Management' section under 'Administration' to minimize the risk of exploitation.
Avoid using the
Name and Description fields in the 'Device Management' section until the issue is resolved. Found an issue in the description? Have something to add? Feel free to write us 👾