PT-2025-12101
CVE-2024-11170
·
Published
2025-03-20
·
Updated
2025-03-22
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
danny-avila/librechat versions prior to 0.7.6
Description
The issue is caused by improper sanitization of file paths by the multer middleware, leading to path traversal. This can result in arbitrary file write and potentially remote code execution.
Recommendations
For versions prior to 0.7.6, update to version 0.7.6 to resolve the issue. As a temporary workaround, consider restricting access to the multer middleware to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾