PT-2025-12103
CVE-2024-11173
·
Published
2025-03-20
·
Updated
2025-03-20
Description by
CVSS 3.1
6.5
MediumMetricsAV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions
danny-avila/librechat versions prior to 0.7.6
Description
The issue occurs when certain API endpoints receive malformed input, resulting in an uncaught exception, which can cause the server to crash and lead to a full denial of service. Although a valid JWT is required to exploit this issue, LibreChat allows open registration, enabling unauthenticated attackers to create an account and perform the attack.
Recommendations
For versions prior to 0.7.6, update to version 0.7.6 to resolve the issue.
As a temporary workaround, consider restricting access to the API endpoints that receive malformed input until the issue is resolved.
Found an issue in the description? Have something to add? Feel free to write us 👾