PT-2025-12310
CVE-2025-0313
·
Published
2025-03-20
·
Updated
2025-03-20
Description by
CVSS 3.1
7.5
HighMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions
ollama/ollama versions prior to 0.3.14
Description
The issue is due to improper validation of array index bounds in the GGUF model handling code. This can be exploited via a remote network, allowing a malicious user to create a GGUF model that can cause a denial of service (DoS) attack.
Recommendations
For versions prior to 0.3.14, update to version 0.3.14 or later to resolve the issue. As a temporary workaround, consider restricting access to the GGUF model handling code to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾