PT-2025-12564

CVE-2025-2689

·

Published

2025-03-17

·

Updated

2025-03-24

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions yiisoft Yii2 versions up to 2.0.45
Description A critical issue has been found, affecting the getIterator function of the file symfonyfinderIteratorSortableIterator.php. This issue leads to deserialization and can be exploited remotely.
Recommendations For versions up to 2.0.45, update to a version higher than 2.0.45 to resolve the issue. As a temporary workaround, consider restricting access to the getIterator function of the SortableIterator.php file until a patch is available.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-88M2-J94X-V4FX
Found an issue in the description? Have something to add? Feel free to write us 👾