PT-2025-12677

CVE-2024-53679

·

Published

2025-03-24

·

Updated

2025-03-27

Description by

CVSS 4.0
8.4
High
MetricsAV:N/AC:L/AT:N/PR:H/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/RE:M
Name of the Vulnerable Software and Affected Versions Apache VCL versions through 2.5.1
Description The issue is related to improper neutralization of input during web page generation, also known as 'Cross-site Scripting', in the User Lookup form of Apache VCL. A user with sufficient rights can craft a URL or be tricked into clicking a URL that will give a specified user elevated rights.
Recommendations For versions through 2.5.1, upgrade to version 2.5.2 to fix the issue. As a temporary workaround, consider restricting access to the User Lookup form until the upgrade is applied.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾