PT-2025-12762
CVE-2025-1452
·
Published
2025-03-04
·
Updated
2025-03-25
Description by
CVSS 3.1
3.5
LowMetricsAV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
Favorites WordPress plugin versions prior to 2.3.5
Description
The issue allows high privilege users, such as admins, to perform Stored Cross-Site Scripting attacks. This can occur even when the unfiltered html capability is disallowed, for example, in a multisite setup. The problem arises because some settings are not properly sanitised and escaped.
Recommendations
For versions prior to 2.3.5, update to version 2.3.5 or later to resolve the issue. As a temporary workaround, consider restricting the ability of high privilege users to modify settings that could be used for Stored Cross-Site Scripting attacks.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾