PT-2025-12804
CVE-2025-30091
·
Published
2025-03-25
·
Updated
2025-03-28
Description by
CVSS 4.0
9.4
CriticalMetricsAV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Name of the Vulnerable Software and Affected Versions
MoxieManager PHP versions prior to 4.0.0
Description
The issue allows unauthenticated attackers to inject and execute arbitrary code through the installer command. Attacker-controlled data to
InstallCommand can be inserted into config.php, and InstallCommand is available after an installation has completed. It is estimated that over 10,500 services are potentially affected.Recommendations
For MoxieManager PHP versions prior to 4.0.0, update to version 4.0.0 or later to resolve the issue. As a temporary workaround, consider disabling the
InstallCommand function until a patch is available. Restrict access to the config.php file to minimize the risk of exploitation. Avoid using the InstallCommand in the affected API endpoint until the issue is resolved. Found an issue in the description? Have something to add? Feel free to write us 👾