PT-2025-12872
CVE-2025-1703
·
Published
2025-03-25
·
Updated
2025-03-26
Description by
CVSS 3.1
6.4
MediumMetricsAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
Ultimate Blocks plugin for WordPress versions up to and including 3.2.7
Description
The issue is related to Stored Cross-Site Scripting via the
content parameter, caused by insufficient input sanitization and output escaping. This allows authenticated attackers with Contributor-level access or higher to inject arbitrary web scripts in pages, which will execute when a user accesses an injected page.Recommendations
For Ultimate Blocks plugin for WordPress versions up to and including 3.2.7, update to a version later than 3.2.7 to resolve the issue.
As a temporary workaround, consider restricting access to the
content parameter to minimize the risk of exploitation. Found an issue in the description? Have something to add? Feel free to write us 👾