PT-2025-1289

CVE-2025-21133

·

Published

2025-01-14

·

Updated

2025-09-09

Description by

CVSS 3.1
7.8
High
MetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Adobe Illustrator versions 3.0.7 and earlier
Description The issue is related to an Integer Underflow (Wrap or Wraparound) that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction, specifically opening a malicious file. This allows an attacker to execute arbitrary code in the context of the current user using a specially crafted malicious file.
Recommendations For versions 3.0.7 and earlier, update to a version later than 3.0.7 to resolve the issue. As a temporary workaround, consider avoiding the use of potentially malicious files until a patch is available. Restrict access to untrusted files to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾