PT-2025-13662
CVE-2025-31043
·
Published
2025-03-29
·
Updated
2025-03-31
Description by
CVSS 3.1
6.5
MediumMetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
Name of the Vulnerable Software and Affected Versions
JetSearch versions 3.5.7 and earlier
Description
The issue is related to Improper Neutralization of Input During Web Page Generation, also known as Cross-site Scripting, which allows DOM-Based XSS in JetSearch. This enables potential attackers to execute malicious scripts on the client-side.
Recommendations
For JetSearch versions 3.5.7 and earlier, update to a version later than 3.5.7 to resolve the issue.
As a temporary workaround, consider restricting user input to prevent malicious scripts from being injected into the web page generation process.
Found an issue in the description? Have something to add? Feel free to write us 👾