PT-2025-13664
CVE-2025-31412
·
Published
2025-03-29
·
Updated
2025-03-31
Description by
CVSS 3.1
6.5
MediumMetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
Name of the Vulnerable Software and Affected Versions
JetProductGallery versions n/a through 2.1.22
Description
The issue is related to Improper Neutralization of Input During Web Page Generation, also known as Cross-site Scripting, which allows DOM-Based XSS in JetProductGallery.
Recommendations
For versions n/a through 2.1.22, update to a version later than 2.1.22 to resolve the issue.
As a temporary workaround, consider restricting user input to prevent malicious scripts from being injected into the web page.
Avoid using potentially vulnerable API endpoints until the issue is resolved.
At the moment, there is no information about additional mitigation measures.
Found an issue in the description? Have something to add? Feel free to write us 👾