PT-2025-14828
CVE-2025-3199
·
Published
2025-04-04
·
Updated
2025-12-08
Description by
CVSS 3.1
9.8
CriticalMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
ageerle ruoyi-ai versions 2.0.1 and earlier
Description
A critical issue affects an unknown functionality of the file ruoyi-modules/ruoyi-system/src/main/java/org/ruoyi/system/controller/system/SysModelController.java in the component's API Interface. This leads to improper authorization and can be exploited remotely.
Recommendations
For versions 2.0.1 and earlier, update to version 2.0.2 to address the issue. As a temporary workaround, consider restricting access to the
SysModelController.java file until the update is applied.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾