PT-2025-15120

CVE-2025-2260

·

Published

2025-04-06

·

Updated

2025-04-06

Description by

CVSS 3.1
7.5
High
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions Eclipse ThreadX NetX Duo versions prior to 6.4.3
Description The issue is related to the NetX HTTP server functionality, where an attacker can cause a denial of service by sending specially crafted packets. This is due to a missing closing of a file in case of an error condition, resulting in a 404 error for each further file request. The problem is a result of an incomplete fix of a previous issue.
Recommendations For versions prior to 6.4.3, consider disabling the PUT request support as a temporary workaround to mitigate the risk of denial of service. Update to version 6.4.3 or later to fully resolve the issue.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Weakness enumeration
Related identifiers
GHSA-F42F-6FVV-XQX3
Found an issue in the description? Have something to add? Feel free to write us 👾