PT-2025-16010

CVE-2025-32697

·

Published

2025-04-10

·

Updated

2025-11-05

Description by

CVSS 2.0
4.0
Medium
MetricsAV:N/AC:L/Au:S/C:P/I:N/A:N
Name of the Vulnerable Software and Affected Versions: MediaWiki versions prior to 1.42.6, 1.43.1
Description: The issue is related to an Improper Preservation of Permissions vulnerability. It affects program files such as includes/editpage/IntroMessageBuilder.Php, includes/Permissions/PermissionManager.Php, and includes/Permissions/RestrictionStore.Php.
Recommendations: For versions prior to 1.42.6, update to version 1.42.6 or later. For version 1.43.0, update to version 1.43.1 or later. As a temporary workaround, consider restricting access to the affected program files until a patch is available.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
BIT-MEDIAWIKI-2025-32697
DSA-5901-1
MGASA-2025-0260
Found an issue in the description? Have something to add? Feel free to write us 👾