PT-2025-16363

CVE-2025-32779

·

Published

2025-04-15

·

Updated

2025-10-27

Description by

CVSS 3.1
6.5
Medium
MetricsAV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:H
Name of the Vulnerable Software and Affected Versions E.D.D.I versions prior to 5.5.0
Description The issue is related to a Zip Slip vulnerability in the E.D.D.I middleware, which connects and manages LLM API bots. An attacker with access to the "/backup/import" API endpoint can write arbitrary files to locations outside the intended extraction directory. Although the application runs as a non-root user, limiting direct impact on system-level files, this vulnerability can still be exploited to overwrite application files, such as JAR libraries, owned by the application user. This overwrite can potentially lead to Remote Code Execution (RCE) within the application's context.
Recommendations For versions prior to 5.5.0, update to version 5.5.0 to resolve the issue. As a temporary workaround, consider restricting access to the "/backup/import" API endpoint to minimize the risk of exploitation. Additionally, restricting access to the vulnerable middleware components can help mitigate the risk until a patch is applied.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-9V34-FRGQ-63MV
Found an issue in the description? Have something to add? Feel free to write us 👾