PT-2025-1647
CVE-2024-11375
·
Published
2025-01-06
·
Updated
2025-01-07
Description by
CVSS 3.1
6.1
MediumMetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
WC1C plugin for WordPress versions up to, and including, 0.23.0
Description
The issue is related to Reflected Cross-Site Scripting due to the use of
add query arg without appropriate escaping on the URL. This allows unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.Recommendations
For versions up to, and including, 0.23.0, update to a version higher than 0.23.0 to resolve the issue. As a temporary workaround, consider restricting access to URLs that use the
add query arg function until a patch is available. Avoid using the add query arg function in URLs that can be manipulated by unauthenticated users until the issue is resolved. Found an issue in the description? Have something to add? Feel free to write us 👾