PT-2025-1654
CVE-2024-11423
·
Published
2025-01-07
·
Updated
2025-01-09
Description by
CVSS 3.1
7.5
HighMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Name of the Vulnerable Software and Affected Versions
The Ultimate Gift Cards for WooCommerce plugin for WordPress versions up to, and including, 3.0.6
Description
The issue is related to a missing capability check on several REST API endpoints, such as
/wp-json/gifting/recharge-giftcard. This allows unauthenticated attackers to modify data, including recharging gift card balances without making a payment and reducing gift card balances without purchasing anything.Recommendations
For versions up to, and including, 3.0.6, update to a version higher than 3.0.6 to resolve the issue.
As a temporary workaround, consider restricting access to the
/wp-json/gifting/recharge-giftcard API endpoint until a patch is available.
Avoid using the affected REST API endpoints until the issue is resolved. Found an issue in the description? Have something to add? Feel free to write us 👾