PT-2025-1692

CVE-2024-11810

·

Published

2025-01-06

·

Updated

2025-01-07

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions PayGreen Payment Gateway plugin for WordPress versions up to and including 1.0.26
Description The issue is related to Reflected Cross-Site Scripting via the message id parameter due to insufficient input sanitization and output escaping. This allows unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action, such as clicking on a link.
Recommendations For PayGreen Payment Gateway plugin for WordPress versions up to and including 1.0.26, update to a version higher than 1.0.26 to resolve the issue. As a temporary workaround, consider restricting access to the message id parameter to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾