PT-2025-1733
CVE-2024-12041
·
Published
2025-01-31
·
Updated
2025-03-02
Description by
CVSS 3.1
5.3
MediumMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Name of the Vulnerable Software and Affected Versions
The Directorist: AI-Powered WordPress Business Directory Plugin with Classified Ads Listings plugin for WordPress versions up to, and including, 8.0.12
Description
The issue allows unauthenticated attackers to extract sensitive data, including usernames, email addresses, names, and more information about users, via the "/wp-json/directorist/v1/users/" endpoint.
Recommendations
For versions up to, and including, 8.0.12, update to a version higher than 8.0.12 to resolve the issue.
As a temporary workaround, consider restricting access to the "/wp-json/directorist/v1/users/" endpoint until a patch is available.
Found an issue in the description? Have something to add? Feel free to write us 👾