PT-2025-1822
CVE-2024-12337
·
Published
2025-01-07
·
Updated
2025-01-08
Description by
CVSS 3.1
6.1
MediumMetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
Shipping via Planzer for WooCommerce plugin for WordPress versions up to, and including, 1.0.25
Description
The issue is related to Reflected Cross-Site Scripting via the
processed-ids parameter due to insufficient input sanitization and output escaping. This allows unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.Recommendations
For versions up to, and including, 1.0.25, update to a version later than 1.0.25 to resolve the issue.
As a temporary workaround, consider restricting access to the
processed-ids parameter to minimize the risk of exploitation. Found an issue in the description? Have something to add? Feel free to write us 👾