PT-2025-18343
CVE-2025-3887
·
Published
2025-04-30
·
Updated
2026-09-14
Description by
CVSS 2.0
10
HighMetricsAV:N/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
GStreamer versions prior to 1.22.0-4+deb12u6
GStreamer versions prior to 1.18.4-3+deb11u5
Description
A stack buffer overflow vulnerability exists in the H.265 codec parser within GStreamer. This vulnerability allows for remote code execution if a malformed media file is processed. The issue stems from insufficient validation of the length of user-supplied data before copying it to a fixed-length stack buffer.
Recommendations
Upgrade to GStreamer version 1.22.0-4+deb12u6 or later.
Upgrade to GStreamer version 1.18.4-3+deb11u5 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾