PT-2025-1872
CVE-2024-12505
·
Published
2025-01-10
·
Updated
2025-01-11
Description by
CVSS 3.1
6.4
MediumMetricsAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
Trackserver plugin for WordPress versions up to, and including, 5.0.2
Description
The issue is related to Stored Cross-Site Scripting via the plugin's 'tsmap' shortcode due to insufficient input sanitization and output escaping on user-supplied attributes. This allows authenticated attackers with contributor-level access and above to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recommendations
For versions up to, and including, 5.0.2, update to a version higher than 5.0.2 to resolve the issue. As a temporary workaround, consider restricting access to the 'tsmap' shortcode to minimize the risk of exploitation. Additionally, restrict contributor-level access and above to authorized personnel only.
Found an issue in the description? Have something to add? Feel free to write us 👾