PT-2025-1917
CVE-2024-12620
·
Published
2025-01-31
·
Updated
2025-03-02
Description by
CVSS 3.1
5.3
MediumMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Name of the Vulnerable Software and Affected Versions
AnimateGL Animations for WordPress – Elementor & Gutenberg Blocks Animations plugin for WordPress versions up to, and including, 1.4.23
Description
The issue is related to a missing capability check on the 'agl json' AJAX action, allowing unauthenticated attackers to update the plugin's settings. This makes it possible for attackers to modify data without proper authorization.
Recommendations
For versions up to, and including, 1.4.23, update to a version higher than 1.4.23 to resolve the issue. As a temporary workaround, consider disabling the 'agl json' AJAX action until a patch is available. Restrict access to the plugin's settings to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾