PT-2025-1947
CVE-2024-12772
·
Published
2025-01-09
·
Updated
2025-03-20
Description by
CVSS 3.1
6.1
MediumMetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
The Ninja Tables WordPress plugin versions prior to 5.0.17
Description
The issue arises from the plugin not sanitizing and escaping a parameter before outputting it back in the page when importing a CSV, leading to a Cross Site Scripting issue.
Recommendations
The Ninja Tables WordPress plugin versions prior to 5.0.17 should be updated to version 5.0.17 or later to resolve the issue.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾