PT-2025-1968

CVE-2024-12854

·

Published

2025-01-07

·

Updated

2025-01-08

Description by

CVSS 3.1
8.8
High
MetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Garden Gnome Package plugin for WordPress versions prior to 2.3.1
Description The Garden Gnome Package plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the functionality that automatically extracts ggpkg files that have been uploaded. This makes it possible for authenticated attackers, with Author-level access and above, to upload arbitrary files on the affected site's server, which may make remote code execution possible.
Recommendations For versions up to and including 2.3.0, update to a version newer than 2.3.0 to resolve the issue. As a temporary workaround, consider disabling the functionality that automatically extracts ggpkg files until a patch is available. Restrict access to the plugin's file upload functionality to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾