PT-2025-20366
CVE-2025-1252
·
Published
2025-05-08
·
Updated
2026-09-22
Description by
CVSS 3.1
7.1
HighMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
Name of the Vulnerable Software and Affected Versions
RTI Connext Professional versions 4.4 through 6.1.2.23
RTI Connext Professional versions 7.0.0 through 7.3.0.7
RTI Connext Professional versions 7.4.0 through 7.5.0
Description
The issue is a heap-based buffer overflow vulnerability in RTI Connext Professional (Core Libraries) that allows overflow variables and tags.
Recommendations
For RTI Connext Professional versions 4.4 through 6.1.2.23, update to a version later than 6.1.2.23.
For RTI Connext Professional versions 7.0.0 through 7.3.0.7, update to a version later than 7.3.0.7.
For RTI Connext Professional versions 7.4.0 through 7.5.0, update to a version later than 7.5.0.
Found an issue in the description? Have something to add? Feel free to write us 👾