PT-2025-20367
CVE-2025-1253
·
Published
2025-05-08
·
Updated
2026-09-22
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
RTI Connext Professional (Core Libraries) versions 4.5 through 6.1.2.22
RTI Connext Professional (Core Libraries) versions 7.0.0 through 7.3.0.6
RTI Connext Professional (Core Libraries) versions 7.4.0 through 7.4.x
Description
The issue is a Buffer Copy without Checking Size of Input, also known as a 'Classic Buffer Overflow' vulnerability, which affects RTI Connext Professional (Core Libraries) and allows overflow of variables and tags.
Recommendations
For versions 4.5 through 6.1.2.22, update to version 6.1.2.23 or later.
For versions 7.0.0 through 7.3.0.6, update to version 7.3.0.7 or later.
For versions 7.4.0 through 7.4.x, update to version 7.5.0 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾