PT-2025-20368
CVE-2025-1254
·
Published
2025-05-08
·
Updated
2026-09-22
Description by
CVSS 3.1
7.4
HighMetricsAV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:H
Name of the Vulnerable Software and Affected Versions
RTI Connext Professional versions 6.0.0 through 6.1.2.23
RTI Connext Professional versions 7.0.0 through 7.3.0.7
RTI Connext Professional versions 7.4.0 through 7.5.0
Description
The issue is an Out-of-bounds Read, Out-of-bounds Write vulnerability in RTI Connext Professional (Core Libraries) that allows Overread Buffers, Overflow Buffers.
Recommendations
For RTI Connext Professional versions 6.0.0 through 6.1.2.23, update to version 6.1.2.23 or later.
For RTI Connext Professional versions 7.0.0 through 7.3.0.7, update to version 7.3.0.7 or later.
For RTI Connext Professional versions 7.4.0 through 7.5.0, update to version 7.5.0 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾