PT-2025-20595
CVE-2025-4447
·
Published
2025-05-09
·
Updated
2025-09-05
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Eclipse OpenJ9 versions up to 0.51
Description
A stack-based buffer overflow can occur when Eclipse OpenJ9 is used with OpenJDK version 8, by modifying a file on disk that is read when the JVM starts.
Recommendations
For Eclipse OpenJ9 versions up to 0.51, update to a version later than 0.51 to resolve the issue.
As a temporary workaround, consider restricting access to files on disk that are read by the JVM at startup to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾