PT-2025-21576
CVE-2025-47287
·
Published
2025-05-15
·
Updated
2026-10-16
Description by
CVSS 2.0
7.8
HighMetricsAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions:
Tornado versions prior to 6.5.0
Description:
The issue allows remote attackers to generate a high volume of logs, constituting a denial-of-service (DoS) attack, by exploiting Tornado's
multipart/form-data parser when it encounters certain errors. The logging subsystem being synchronous compounds this DoS. The vulnerable parser is enabled by default.Recommendations:
For versions prior to 6.5.0, upgrade to Tornado version 6.5.0 to receive a patch.
As a temporary workaround, consider blocking
Content-Type: multipart/form-data in a proxy to mitigate the risk.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾