PT-2025-2160
CVE-2024-13406
·
Published
2025-01-21
·
Updated
2025-01-24
Description by
CVSS 3.1
6.1
MediumMetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
XML for Google Merchant Center plugin for WordPress versions up to, and including, 3.0.11
Description
The issue concerns Reflected Cross-Site Scripting via the
feed id parameter due to insufficient input sanitization and output escaping. This allows unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.Recommendations
For versions up to, and including, 3.0.11, update to a version later than 3.0.11 to resolve the issue. As a temporary workaround, consider restricting access to the
feed id parameter to minimize the risk of exploitation. Found an issue in the description? Have something to add? Feel free to write us 👾